本記事は、AddressLook Premiumをご利用いただいているお客様が対象です。
Exchange 管理センターにて登録していたAddressLook Premiumアドインが、
Microsoft 365管理センターの[統合アプリ]や[アドイン]内にて表示されない事象が発生する場合がございます。
【原因】
現在、AddressLook Premiumを含むOfficeアドインは、Microsoft 365管理センター内にて管理されておりますが、以前はExchange管理センターにて管理されていました。
管理画面の変更に伴い、通常はExchange管理センターで登録したOfficeアドインも自動的に
Microsoft 365管理センターに移行されるところ、正常に移行されなかった場合、本事象が発生します。
【確認方法】
Exchange管理センターにて登録したAddressLook Premiumアドインが、Microsoft 365 管理センター内に表示されない場合、
まずは下記方法にて、Microsoft 365テナント内にAddressLook Premiumが登録されているかご確認をお願いいたします。
===
1)PowerShellをローカルPCの管理者権限にて起動します。
2)下記コマンドを入力し、Exchange Online PowerShell モジュールのインストールを実施します。
[コマンド]
Install-Module -Name ExchangeOnlineManagement
2)下記コマンドを入力し、Exchange Online PowerShell モジュールのインポートを実施します。
[コマンド]
Import-Module ExchangeOnlineManagement
3)下記コマンドを入力し、対象となるExchange Onlineに接続します。
[コマンド]
Connect-ExchangeOnline -UserPrincipalName <Exchange Onlineの管理者のUPN>
例)
※Exchange Onlineの管理者アカウントが[ContosoExadmin@contoso.co.jp]の場合
Connect-ExchangeOnline -UserPrincipalName ContosoExadmin@contoso.co.jp
4)下記コマンドを入力し、お客様環境にインストールされたアプリケーション一覧を出力します。
[コマンド]
Get-App -OrganizationApp| Format-List > [出力先パス]
例)Cドライブ内Workフォルダに[Get-App一覧]というファイル名でテキスト出力する場合
Get-App -OrganizationApp| Format-List > "C:\Work\Get-App一覧.txt"
5)アプリケーション一覧の中に[AddressLook Premium]が含まれているかご確認ください。
===
【対応方法】
AddressLookがMicrosoft 365テナントにインストールされているものの
Microsoft 365管理センターにてOfficeアドインが表示されない場合は、
Microsoft社より、手動での移行として該当するOfficeアドインを削除後、再度Officeアドインを追加する方法が案内されております。
お客様環境においても、下記手順を参照しAddressLook Premiumアドインの移行を
実施することを検討頂けますようお願いいたします。
なお、AddressLook Premiumアドインを削除しても階層型アドレス帳の情報は削除されませんが、
再度アドインが追加されるまで一時的に利用者様においてAddressLook Premiumが
利用できなくなることをご留意ください。
また、移行の際にAddressLook Premium v2の導入もご検討ください。
AddressLook Premium v2の要件や機能の詳細については、下記記事を参照ください。
システム条件:AddressLook
[AddressLook Premium / AddressLook for Teams]新アプリ「AddressLook Premium v2」のリリースなど
===
1.Exchange Online PowerShellを使用したAddressLook Premiumの削除
1)【確認方法】項番4にて出力したアプリケーション一覧より、AddressLook Onlineの [AppID]を確認します。
2)PowerShellをローカルPCの管理者権限にて起動します。
3)下記コマンドを入力し、Exchange Online PowerShell モジュールのインストールを実施します。
[コマンド]
Install-Module -Name ExchangeOnlineManagement
4)下記コマンドを入力し、Exchange Online PowerShell モジュールのインポートを実施します。
[コマンド]
Import-Module ExchangeOnlineManagement
5)下記コマンドを入力し、対象となるExchange Onlineに接続します。
[コマンド]
Connect-ExchangeOnline -UserPrincipalName <Exchange Onlineの管理者のUPN>
例)
※Exchange Onlineの管理者アカウントが[ContosoExadmin@contoso.co.jp]の場合
Connect-ExchangeOnline -UserPrincipalName ContosoExadmin@contoso.co.jp
6)下記コマンドを入力し、お客様環境にインストールされたAddressLook Premiumをアンインストールします。
[コマンド]
Remove-App -OrganizationApp -identity <項番1で確認した値>
例)AddressLook PremiumのApp IDの値が[7a774f0c-7a6f-11e0-85ad-07fb48240]だった場合
Remove-App -OrganizationApp -Identity 7a774f0c-7a6f-11e0-85ad-07fb48240
7)コマンド実行後、Get-App -OrganizationAppを実施し、アプリケーション一覧の中に[AddressLook Premium]が含まれていないことを確認ください。
---
2.AddressLook Premiumの追加
下記ドキュメント項目を参照し、AddressLook Premiumの追加を実施ください。
◇クライアント導入設定ガイド
3. AddressLook Premium の設定
3.1.1 アドインの有効化
※アドインの有効化後、AddressLook Premiumのアドインが利用者のOutlookおよび
Outlook on the Webへ展開されるまでに24時間以上かかる場合がございます。
アドインが表示されない場合は、恐れ入りますが時間を置いて
ご確認くださいますようお願いいたします。
---
3.Microsoft 管理センターにてAddressLook Premiumの確認
下記URL内にAddressLook Premiumアドインが表示されているかご確認をお願いいたします。
□統合アプリ
https://admin.microsoft.com/Adminportal/?#/Settings/IntegratedApps
===