事象
LogLook+ポータルにアクセスした際に、下記のエラー「AADSTS50105」が表示されてサインインできません。
表示されるエラー画面(※エラー画面は、ご利用環境によって多少異なる場合があります。)
原因
LogLook+ポータルへのアクセスには、Microsoft 365の認証を使用しており、アクセスできるユーザーはMicrosoft Entra(旧:Azure AD)の設定画面から制限することができます。
Microsoft 365の認証時に、エラー番号[AADSTS50105]を含むエラーメッセージが表示された場合は、Microsoft 365にサインインしているユーザーに対して、Microsoft Entra管理センターに登録されている、LogLook+用のアプリケーション「LogLook_ReportService」の使用が制限されていることが考えられます。
対応方法
Microsoft Entra の設定画面で、LogLook+用のアプリケーション「LogLook_ReportService」にユーザーへのアクセス許可を付与することでアクセスできるようになります。
LogLook+用のアプリケーション「LogLook_ReportService」に対する、ユーザーへのアクセス許可を付与する手順については、下記を参照ください。
■LogLook+ > 管理者ガイド > アクセスユーザーの管理
アクセス制御の設定
LogLook+用のアプリケーション「LogLook_ReportService」に対する、ユーザーへのアクセス許可を付与する手順については、下記を参照ください。
■LogLook+ > 管理者ガイド > アクセスユーザーの管理
アクセス制御の設定
参考情報
エラー番号[AADSTS50105]のエラーについては、Microsoft社より公開されているアプリケーションエラーに関する公開情報を併せてご参照ください。
■エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てられない
https://learn.microsoft.com/ja-jp/troubleshoot/azure/active-directory/error-code-aadsts50105-user-not-assigned-role
■エラー AADSTS50105 - サインインしているユーザーがアプリケーションのロールに割り当てられない
https://learn.microsoft.com/ja-jp/troubleshoot/azure/active-directory/error-code-aadsts50105-user-not-assigned-role